Need help?

Please type a word or phrase into the box below to search all our FAQ and support articles.

Prerequisites for PDF417

Follow

PDF417.mobi requirements - Android

Even before settings the license key, you should check if PDF417.mobi is supported on current device. This is required because the PDF417.mobi is a native library that needs to be loaded by the JVM and it is possible that it doesn't support the CPU architecture of the current device. The attempt of calling any methods from the SDK that rely on native code, such as license check, on a device with unsupported CPU architecture will cause a crash of your app.

PDF417.mobi requires Android 4.1 as the minimum android version. For best performance and compatibility, we recommend Android 5.0 or newer.

Camera video preview resolution also matters. In order to perform successful scans, camera preview resolution cannot be too low. The minimum camera preview resolution in order to perform a scan is 480p. It must be noted that camera preview resolution is not the same as the video record resolution, although on most devices those are the same. However, there are some devices that allow recording of HD video (720p resolution) but do not allow high enough camera preview resolution (for example, Sony Xperia Go supports video record resolution at 720p, but camera preview resolution is only 320p - PDF417.mobi does not work on that device).

PDF417.mobi is native application, written in C++ and available for multiple platforms. Because of this, PDF417.mobi cannot work on devices that have obscure hardware architectures. We have compiled PDF417.mobi native code only for most popular Android ABIs. See Processor architecture considerations for more information about native libraries in PDF417.mobi and instructions on how to disable certain architectures in order to reduce the size of the final app.

 

PDF417.mobi requirements - iOS

SDK package contains the Microblink framework and one or more sample apps that demonstrate framework integration. The framework can be deployed in iOS 8.0 or later, iPhone 4S or newer, and iPad 2 or newer.

SDK performs significantly better when the images obtained from the camera are focused. Because of that, the SDK can have lower performance on iPad 2 and iPod Touch 4th gen devices, which don't have camera with autofocus.

 

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

Comments

  • Avatar
    Aymane Moujdi

    Salm labss

  • Avatar
    Vitor Santos

    ñ que pegá nó meo celular Samsung Android